Version 14 (modified by mark1, 10 years ago) (diff)

--

Tips for using Microstation and Terrascan for LIDAR QC

Open Microstation and read in the empty_3D example design file. This is laid out for the QC procedure. Make sure you always use a 3D design file for LIDAR data else you will not be able to profile the data. To start TerraScan, goto Utilities > MDL applications and select TSCAN (and TMODEL if surfaces are to be generated).

If you need to make a new 3D design file, easiest way I have found to do this is create a new 2D one, then export as 3D and re-load it. Click the lightning bolt icon at the bottom of the views and change to "hidden line" displays (this removes the visible grid). Save settings from File menu.

Load in LAS data

To load in the LAS data you can select Read Points from the TerraScan File menu. Select the LAS files to read in and click Add. Then click Done. On the next dialog pop-up, do not apply WGS84 or any transforms. The only thing you should need to change is the Flightline Numbering to "increase by file". The points should be displayed in view 1.

If you have a lot of LAS files to load in then you may need to use a "fence". This is essentially an area of interest. If you open one LAS file and then draw a fence using the Microstation toolbar, using the displayed points as a guide to the area of interest. Then close the points, and open all the LAS files, selecting the "inside fence only" option from the Load Points dialog.

Changing display properties

From the TerraScan menu select View > Display mode. This is the main dialog for changing how the data looks. EG you can view data by intensity, echo, flight line, class etc. If the display contrast looks odd, select colours and autofit, then apply the changes. Speed should always be normal, unless you want to view the flight directions, in which case select colour by flightline and speed as slow. Zoom functions are on the toolbar on the bottom of the view windows. View windows can be synchronised so that, for example, you can view intensity and elevation at the same points. BEWARE the colour scale for viewing by echo, first two colours both mean 1st return (one when only 1 return, one when first of many).

Draw Profiles

Use the Draw Profile tool button on the TerraScan toolbar (looks like A-A). On the mini-dialog that opens, select view 2 and a depth (e.g. 0.5m). Then you should be able to draw profiles and they will appear in view 2. Can use the Microstation measurement tool (from the toolbar) to measure vertical/horizontal distances (useful when comparing accuracy of overlapping flight lines).

Point classification

This is an important part of the QC procedure to remove noisy points. You can make a macro and save it to use again. See the LIDAR notes for more info on how to classify the points. Once classified we may want to strip the points of a certain classification off the LAS file. (Example - low points). This can be done by selecting "Point -> Delete -> By point class". Then select the class you want to delete. You can use "Classify -> Add point to ground" to add individual/groups of points to a certain class by selecting them. This is important because your classification routine will most likely misclassify some points.

To remove haze layers, you can classify by elevation selecting points, say, >200m off the ground and classifying them as low points. It is suggested that all points to be removed be classified as low points (even if they are high).

The main steps to set up a Macro are to select tools -> Macro. Then classify "from any -> default" to get everything the same classification. Then "default -> low (group)", "default -> low (single)" and then classify isolated points "any -> low". This should classify all the overtly noisy points to low points. Test the macro at this stage and see if it is classifying correctly. If so, add the ground classification to the macro, "default -> ground" and re-test the macro. This is the basic ground classification macro. Save it to a file for future re-use.

Creating Projects in TerraScan

This is untested as of yet Projects in TerraScan are useful for showing trajectories and splitting/combining LAS files. It is often easier to use a project when processing large quantities of data. To create a new project select the option from the toolbar (looks like offset stacked rectangles). Then file->new. Select LAS storage, scanner airborne and give it a description. Blocks can be used/placed which allows the data to be split up into sections. When placing blocks try to get an even amount of data in each one, and make sure they are flush together so that no data is ignored. Blocks can be automatically generated when importing the data. Select File->import points to project. Macros can be run on the data to classify it, the macro can run on all blocks or just a selection of blocks. The results can either overwrite the previous data or new copies made.

WARNING Projects appear to stay in the Microstation design files. So if you are going to make a new project, copy the design file first.