Opened 11 years ago

Closed 11 years ago

#108 closed support (fixed)

Support: 28/Mar/2008, Chris Hecker, WM06/06

Reported by: mggr Owned by: mggr
Priority: immediate Milestone:
Component: Support Keywords:
Cc: Other processors:

Description

New contact from Chris with some atmospheric correction questions (note #42 for previous support)

Hi Mike;
 
after a few months of radio silence, I have a question for you again! ;-)
 
I am wanting to do atmospheric correction on the 2006 Mojacar Eagle and Hawk data with ATCOR4 ( http://www.rese.ch/atcor/atcor4/index.html). For that I need to also input
- a sun elevation and sun azimuth file (which I should be able to do with some freeware software)
- a scan angle file  with the viewing vector for each pixel (azimuth angle, zenith, angle, height of plane).
 
Gary mentioned that you may be the person best suited to judge which workaround or tool from the user community is available for that. He mentioned that Matt Disney from London had retro-engineered the info in the past for BRDF studies.
Do you know anything about that and are these tools(?) available?
 
 
The other question is about the metadata info in the hdf file.
 
I presume that folder "Navigation" contains info from the plane's IMU (NVhead, NVpitch NVroll), and GPS (NVlat NVlng NVhgt)
 
and that the folder "Coordinates" contains info from a ?second IMU (COhead, COpitch COroll) and a ?second GPS (COlat, CO lng, COhgt) which are positioned near the instruments.
 
Is that correct? What do the values in COqual represent? Do you have a document that explains the different tags in the hdf file? That would be ideal.
 
 
Thanks and cheers from Holland,
Chris 

From: Chris Hecker
Sent: Friday, February 22, 2008 4:46 PM
To: 'Gary Llewellyn'
Subject: Info and GLT

Hi Gary;
I have a "couple" of questions. Maybe some are to be forwarded to Phil or somebody else from the processing team.
 
a) did you get the DGPS data from the ftp site? Please let me know when you manage to download the stuff so I can remove it.
b) the Ethiopia SIM card that you gave to me expires in April. I presume you wont need it back. Otherwise let me know.
c) is there a location on the ARSF site where we can see processing progress? I was also wondering if I could find the updated sortie briefs or a shape file that has the final coordinates of all areas flown in the Ethiopia campaign. An ethiopian student was asking me since he wanted to know in what areas hyperspectral data will become available later on.
 
d) this is maye a tricky one. I am looking at the data from 2006 Spain (Mojacar, PI  = Teeuw). I had eventually figured out the geomcorrection with azgcorr. 
Now for the atmospheric correction we want to use ATCOR 4 (programmed by Rolf Richter  DLR and I think Iten from Zuerich). One of the input parameters for the atmospheric correction model is the viewing geometry and distance between plane and each pixel.
this can be supplied either as:
- a geo lookup table (GLT) that defines a map coordinate of each pixel while still in image coordinates
- a scan angle file  with the viewing vector for each pixel (azimuth angle, zenith, angle, height of plane).
 
I looked in the supplied hdf file that accompanies the BIL files. From the coordinate info I should be able to extract the vector for each pixel, but its a lot of work to calculate that.
Do you have a tool that could do this for me? In principle one of the modules of the azgcorr suit has to do a similar calculation for the geocorrection. Is it possible to extract this info ourselves or get it from one of you?
 
What are other people doing about the atmospheric correction of the Eagle and Hawk data? Have you heard any expereinces from other research teams?

Change History (4)

comment:1 Changed 11 years ago by mggr

  • Status changed from new to assigned

Sent him info on the current state of coordinate availability and created ticket #109. Described the navigation systems and what the coordinate vectors were.

comment:2 Changed 11 years ago by mggr

Chris replied with:

> > Could you link us to the software you have in mind?  It might 
> > be useful to be able to pass on to other users too :) 
IN the past, I used various sun position calculators on the internet
(for a single entry only). have not really found a good tool yet that
could also calculate that automatically for an entire, long flightline.
will pass it on when I come across.

> > I'm not aware of Matt's retro-engineering - we'll follow that 
> > up and see if what he did was generic enough to be useful to 
> > others. 

Hand contact with Mat already. He has been very helpful and will send
the tools. It seems that it is a combination of individual tools and
libraries in C environment. I will try them out (I think they were
developed for CASI but should work / shoudl be adaptable to Eagle/Hawk)
and let you know about its usefulness for other users.

> > If you did want to write a 
> > tool yourself, note there are some small differences for the 
> > CASI sensor - there is some information in the CASI volgroup 
> > for correcting lens distortion (let me know if you want the 
> > full details on this).

I probably wont be working with the CASI data. Is there some information
about the distortions and gemoetry of the Eagle and Hawk sensor as well?
something like the CASI CCD pixel view angle table?

Or can we assume that the ifov's for adjacent CCDs are contiguous next
to each other and that the CCD of the nth pixel off NADIR is pointing
n*ifov to the side from vertical?


>> > > The other question is about the metadata info in the hdf file.
> > The best documentation so far is at the back of the azgcorr 
> > manual.  

Thanks for the details on the different folders in the hdf file. I have
userguide v3.0 from 2005. I presume that this is still up to date.
Will have a look at the azexhdf if the tools from Mat do not do the
trick.

comment:3 Changed 11 years ago by mggr

Confirmed we have no distortion file for Eagle, linked Chris to the Specim thesis.

comment:4 Changed 11 years ago by mggr

  • Resolution set to fixed
  • Status changed from assigned to closed

Closing this one for now, as it's superseded by other contacts.

Note: See TracTickets for help on using tickets.