Opened 10 years ago

Closed 9 years ago

Last modified 3 years ago

#244 closed flight processing (fixed)

GB08/12, flight day 152a/2009, Borth Bog

Reported by: jatt Owned by: knpa
Priority: alpha 4 high Milestone: 2009 Data processing completion
Component: Processing: general Keywords:
Cc: Other processors: benj

Description (last modified by knpa)

Data location: ~arsf/arsf_data/2009/flight_data/uk/GB08_12-2009_152a_Borth_Bog

Data arrived from ARSF via SATA disk M on 9th June 2009.

Scientific objective: see ~arsf/arsf_data/in_progress/2008/ARSF_Applications/GB_and_NL/GB08-12 Application Form and Science Case.pdf

Priority: α4H

PI: Angela Harris

Sensors:

  • Eagle (20/11/10)
  • Hawk (20/11/10)
  • Leica LIDAR (29/01/10)
  • RCD (29/01/10)

Change History (40)

comment:1 Changed 10 years ago by jatt

Both eagle and hawk raw files for flight line 2 are very small (eagle 51M and hawk 12M), suggesting little or no data for that flight line.

comment:2 Changed 10 years ago by jatt

Requested vectors from Gary.

comment:3 Changed 10 years ago by jatt

  • Owner set to knpa

comment:4 Changed 10 years ago by knpa

Timestamps do not match between LIDAR (and webcam) and Eagle/Hawk

comment:5 Changed 10 years ago by knpa

According to Phil, timestamps for the folders (and therefore the lidar and jpgs filenames) are two hours FAST (i.e. a 9am flightline appears as 11am).
In addition, some of the jpegs have even further off timestamps (4 hrs in one case) but this has just been seen for test lines so far.

comment:6 Changed 10 years ago by knpa

Some flightlines do not have sync info (Eagle lines 1-3 and hawk line 2 so far). Having to correct SCT by hand, will have to check against vectors when they arrive.

comment:7 Changed 10 years ago by knpa

All eagle flightlines missing sync info (didn't realise they share a single .nav file).
Will adjust SCT to minimise wobbles and then correct to an acceptable accuracy with vectors on arrival.

comment:8 Changed 10 years ago by knpa

A regular drop of scan lines on Hawk flightline #11 resulting in 4 across track black lines approx 7 pixels wide.

comment:9 Changed 10 years ago by knpa

SCTs found for all flightlines (despite lack of sync info).
Awaiting arrival of vectors before can proceed to delivery checking.

comment:10 Changed 10 years ago by knpa

Have contacted PI and they are happy to wait a couple of weeks for vectors.

comment:11 Changed 10 years ago by chrfi

  • Owner changed from knpa to chrfi

starting lidar processing

comment:12 Changed 10 years ago by mark1

Vectors have arrived.

comment:13 Changed 10 years ago by mggr

Re: #281 (Hawk frame rates are double what they should be), the following lines are affected and the .hdr file will need to be edited to halve the fps number:

uk/GB08_12-2009_152a_Borth_Bog/hawk/Hawk152-09-2.hdr: predicted length half recorded length, frame rate doubling problem

comment:14 Changed 10 years ago by chrfi

  • Owner chrfi deleted

comment:15 Changed 10 years ago by knpa

halved fps in .hdr for H2 from 40 to 20

comment:16 Changed 10 years ago by knpa

  • Owner set to knpa
  • Status changed from new to assigned

comment:17 Changed 10 years ago by benj

  • Owner changed from knpa to benj
  • Status changed from assigned to new

Taking ticket for delivery checking

comment:18 Changed 10 years ago by benj

  • Other processors set to benj

Delivery check done, comments:

  • Flightline numbers need to be corrected in the readme (currently all XXX) - should match output to input flightline
  • Correct description of screenshots directory in the readme
  • Readme typo - "A regular drop of scan lines on Hawk flightlines resulting in approx. 4 across track black (~7 pixels wide) per flightline." - should be "...black lines per flightline."
  • DEM filename in azgcorr example command should be an exact filename, not a wildcard match (eg. borth_bog.dem)
  • azgcorr example command shouldn't have a \ on the end of the last line
  • Filenames for azgcorr example commands should match those delivered (ie no "b" on the end of the level 1 filename, 01 rather than 1)
  • Pixel size description requires units (1m x 1m, not 1x1)
  • Fax number for ARSF ops is 01452 713219 (I'll update the template)

Other issues:

  • Eagle lines 1, 3, 10, 11, 12 - number of lines in the header file does not agree with the file size (off by 3-4 lines)
  • Hawk lines 1-12 - number of lines in the header file does not agree with the file size (off by >40 lines). Also looks like it's included dark frames in the level 1. Band 232 is completely black in all images.

comment:19 Changed 10 years ago by benj

  • Owner changed from benj to knpa
  • Status changed from new to assigned

comment:20 Changed 10 years ago by benj

Dark line issue in ticket #287

comment:21 Changed 10 years ago by knpa

HYPERSPECTRAL DATA DELIVERED

comment:22 Changed 10 years ago by knpa

Lidar data issue(s)

The two higher altitude flightlines' points are hundreds of meters in absolute value above the lower flightlines.
Tried offsetting height through ALSPP. Got one of the flightlines to the same level but higher flightline exhibits a 'banana' effect in which the centre is higher than the edges.
emca thinks problems could possibly be caused by a program version issue. There is a .sup file which is generated by newer versions of IPAS and is used by ALSPP - this is not present. Has suggested reprocessing navigation from start with new version of IPAS.

comment:23 Changed 10 years ago by knpa

On investigation have discovered that the height error originates in the original .scn files i.e. the range value is wrong by around 1.5km (for the two high flightlines only). Have e-mailed Phil @ ops about the problem, awaiting reply.

comment:24 Changed 10 years ago by knpa

Delivery prepared, awaiting delivery check.

comment:25 Changed 10 years ago by emca

  • Owner changed from knpa to emca

comment:26 Changed 10 years ago by emca

Delivery check for LIDAR data complete.
Removed the .svn directories from the bin folder. Renamed the ascii laser files (had incorrect project code & julian day). Loaded data into grass and looks good.
Ready for delivery.

comment:27 Changed 10 years ago by knpa

  • Owner changed from emca to knpa

comment:28 Changed 10 years ago by knpa

rsynced back to repository

comment:29 Changed 10 years ago by knpa

  • Description modified (diff)

LIDAR and photography delivered today (29/01/10)

comment:30 Changed 10 years ago by knpa

  • Component changed from Processing: general to Archiving

Ready for archiving

comment:31 Changed 9 years ago by knpa

Found that LIDAR was originally processed with wrong calibration file.
Have reprocessed lines and sent out again on disk today.

comment:32 Changed 9 years ago by knpa

*NOTE need to rsync this project again before archiving.

comment:33 Changed 9 years ago by knpa

  • Component changed from Archiving to Processing: general

comment:34 Changed 9 years ago by knpa

  • Description modified (diff)

comment:35 Changed 9 years ago by knpa

This project has been r-synced.

comment:36 Changed 9 years ago by knpa

Started archiving.

Creating separate delivery directory for the reprocessed lidar that was sent out in June.

comment:37 Changed 9 years ago by knpa

Archiving complete. Awaiting NEODC downloading.

comment:38 Changed 9 years ago by knpa

Downloaded and backed-up by NEODC.

Moved to archive disk.

comment:39 Changed 9 years ago by knpa

  • Resolution set to fixed
  • Status changed from assigned to closed

Deleted workspace copy.

Closing ticket.

comment:40 Changed 3 years ago by asm

Archiving

Re-processed hyperspectral data has been archived and everythin is ready to be downloaded from CEDA. Will close this ticket.

Note: See TracTickets for help on using tickets.