Opened 9 years ago

Closed 9 years ago

#302 closed bug (fixed)

when zooming on overview and profile pixels jiggle

Reported by: chrfi Owned by: harg
Priority: alpha 5 Milestone:
Component: LAG Keywords: jiggle zooming
Cc: Other processors:

Description

Build number: 2010.01.18.1
system : pmpc974

to reproduce, run LAG with no arguments and click file, open, select any LAS file and load it. now when zooming in and out of a set spot the pixels will appear to jiggle, they are moving position with each zoom increment with relation to each other.the expected result is that the pixels expand outwards but don't move relativly.

Change History (2)

comment:1 Changed 9 years ago by harg

  • Owner changed from emca to harg
  • Status changed from new to accepted

I am currently working on this. I think that this is caused by the fact that most graphics cards using OpenGL do float calculations only, not doubles, which, with enough calculations and large enough magnitudes of the coordinate values (such that values may be 200000.003... and so on) can cause large errors to occur. I aim to fix this by replacing certain OpenGL convenience functions, such as glOrtho and gluLookAt, which are evaluated on the graphics card and, therefore, with floats, with my own which calculate the matrices using doubles and then, finally, pass the completed matrice to the graphics card, to be converted to floats AFTER calculation, rather than before.

comment:2 Changed 9 years ago by harg

  • Resolution set to fixed
  • Status changed from accepted to closed

FIXED. Solution was to use a pre-existing variable as an offset directly rather than passing it to OpenGl to work on, causing the points to be drawn close to the origin and, therefore, with more precision.

Note: See TracTickets for help on using tickets.