Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#8 closed flight processing (fixed)

271-WM06-17-Vigo

Reported by: amro Owned by: mggr
Priority: immediate Milestone: 2006 data processing completion
Component: Processing: general Keywords: 271, wm06-17, vigo
Cc: mggr Other processors:

Description (last modified by mggr)

ATM processing :
After processing ATM, every thing seems to be okay, however, there are some funny color ( red, yallow) appear on the top of the image. (Peter said that we can deliver them as they are). The data can be delivered because these lines appeared on the top of clouds.

CASI processing :
Line one seems to be okay, however line 2 and 3 are bugged. error messages are shown below.

For line 2

azcas2
using calibration file:  /users/rsg/arsf/calibration/casi/in34a4.rad  for aperture: 4
casi IMAGE bands: 14 pixels: 512 lines: 62
no SRC processed or not present
casi ILS bands: 14 pixels: 1 lines: 62
Using RSC calibration file: /users/rsg/arsf/calibration/casi/in34a4.rad
NB: aperture from file search: 4

Creating dark data array...
Dark frames used: 100  seq_ids: 52  to: 151
skipping 90 start frames on file: 0
Data processed using CASI read routine: frame_cal_dark

line:      0  seq_id:    242
first image line (0) was seq id: 242
last  image line (61) was seq id: 303
Updated hdf file is: ./lev1/c271021b.hdf
./runc/c27102.sh: line 176:  4206 Segmentation fault      aznav ${V} ${ATT} ${POS} -f 7 7 1 -so ${SCTOFF} -at ${GPTOFF} 0.0 -ao 0 0 0 ${ACVE} -h ${P_HDF1}

For line 3

azcas2
using calibration file:  /users/rsg/arsf/calibration/casi/in34a4.rad  for aperture: 4
casi IMAGE bands: 14 pixels: 512 lines: 3951
no SRC processed or not present
casi ILS bands: 14 pixels: 1 lines: 3951
Using RSC calibration file: /users/rsg/arsf/calibration/casi/in34a4.rad
NB: aperture from file search: 4

Creating dark data array...
Dark frames used: 100  seq_ids: 52  to: 151
skipping 90 start frames on file: 0
Data processed using CASI read routine: frame_cal_dark

line:      0  seq_id:    242
line:   1000  seq_id:   1242
line:   2000  seq_id:   2242
line:   3000  seq_id:   3242
first image line (0) was seq id: 242
last  image line (3950) was seq id: 4192
Updated hdf file is: ./lev1/c271031b.hdf

Change History (11)

comment:1 Changed 12 years ago by mggr

  • Description modified (diff)
  • Owner changed from amro to mggr
  • Status changed from new to assigned

I'm having a go at reproducing.

comment:2 Changed 12 years ago by mggr

Reproduced, but I only get c27101 to process - everything else fails (3 ATM, 2 CASI).

ATM seems to fail in azatm (seg fault). The two failed CASI fail in aznav (seg fault).

I'm suspicious of bad data, but think we need Bill's help to diagnose, will email.

comment:3 Changed 12 years ago by amro

  • Priority changed from blocker to minor

ATM and CASI processed on the 11 of May seems to be okay however, the fault in segmentation is still present. Ricky said it fine to be delivered ( + Peter said ok).

comment:4 Changed 12 years ago by amro

casi line 2 and 3 processed to level one only, however, the process failed when doing level 3. I think it is something to do with the Applanix

error message for line 3
azimport -- ver: 2.2.10 May 7 2007 (C) Azimuth Systems UK 1996, 2007

Applanix sbet file: ./app/app/Proc/apa06271.sbt
Site time limits - day: 271 start: 164000 end: 164800
date: 28 09 2006 jday: 271 utc2gps: 14.0
NAV vgroup exists - updating

Nav records per second from Applanix sbet file: 200.00
Using: 0.01 seconds for gap check
site time limits: 60000.00 to: 60480.00
day starts at secs: 345600.0
i: 0 t: 405600.002643 s: 60000.002643 lat: 42.104160 lng: -8.990437 alt: 3158.4

prhw: 5.4033 -5.5144 78.7221 -0.0873

i: 96000 t: 406817.014165 s: 61217.014165 lat: 42.226605 lng: -8.630269 alt: 312.4

prhw: 0.4086 1.5237 -142.0467 -0.1720

Overall site limits - day: 271 start: 164000 end: 164759
vector lengths: 96001
item: 25 nav file to hdf: apa06271.sbt

Updated HDF file: ./lev1/c271031b.hdf


azcas2 -- ver: 2.0.3 Mar 27 2005 (C) Azimuth Systems UK 1996, 2005

User supplied CASI pixel angle table size: 512 from file: /users/rsg/arsf/calibration/casi/NERC253_527tan.txt
Scan line limits from HDF file: 242 to 4192
CASI data from file: ./casi/cagc004.271

CASI file header.....

CH casi_serial : 2007
CH sw_version : 5c.03oAlphaR$
CH y, m, d : 2048 0 0
CH h, m, s, msec : 0 27 53 278
CH mode : 0
CH tape file num : 4
CH aperture : 1 (frame headers value: 4)
CH ppFrame : 0
CH pps : 1
CH integ_time : 88.000000
CH num_pixels : 512
CH num_pixels_src : 0
CH src_row : 142
CH num_bands : 15
CH num_chans : 15
CH num_darkFrames : 200
CH num_looks : 39
CH look_spacing : 4
CH center_look : 256
CH summed channels : 1
CH ils_col : 138779448

using calibration file: /users/rsg/arsf/calibration/casi/in34a4.rad for aperture: 4
casi IMAGE bands: 14 pixels: 512 lines: 3951
no SRC processed or not present
casi ILS bands: 14 pixels: 1 lines: 3951
Using RSC calibration file: /users/rsg/arsf/calibration/casi/in34a4.rad
NB: aperture from file search: 4

Creating dark data array...
Dark frames used: 100 seq_ids: 52 to: 151
skipping 90 start frames on file: 0
Data processed using CASI read routine: frame_cal_dark

line: 0 seq_id: 242
line: 1000 seq_id: 1242
line: 2000 seq_id: 2242
line: 3000 seq_id: 3242
first image line (0) was seq id: 242
last image line (3950) was seq id: 4192
Updated hdf file is: ./lev1/c271031b.hdf

error message for line 2
azcas2 -- ver: 2.0.3 Mar 27 2005 (C) Azimuth Systems UK 1996, 2005

User supplied CASI pixel angle table size: 512 from file: /users/rsg/arsf/calibration/casi/NERC253_527tan.txt
Scan line limits from HDF file: 242 to 303
CASI data from file: ./casi/cagc003.271

CASI file header.....

CH casi_serial : 2007
CH sw_version : 5c.03oAlphaR$
CH y, m, d : 2048 0 0
CH h, m, s, msec : 0 26 52 852
CH mode : 0
CH tape file num : 3
CH aperture : 1 (frame headers value: 4)
CH ppFrame : 0
CH pps : 1
CH integ_time : 88.000000
CH num_pixels : 512
CH num_pixels_src : 0
CH src_row : 142
CH num_bands : 15
CH num_chans : 15
CH num_darkFrames : 200
CH num_looks : 39
CH look_spacing : 4
CH center_look : 256
CH summed channels : 1
CH ils_col : 162466464

using calibration file: /users/rsg/arsf/calibration/casi/in34a4.rad for aperture: 4
casi IMAGE bands: 14 pixels: 512 lines: 62
no SRC processed or not present
casi ILS bands: 14 pixels: 1 lines: 62
Using RSC calibration file: /users/rsg/arsf/calibration/casi/in34a4.rad
NB: aperture from file search: 4

Creating dark data array...
Dark frames used: 100 seq_ids: 52 to: 151
skipping 90 start frames on file: 0
Data processed using CASI read routine: frame_cal_dark

line: 0 seq_id: 242
first image line (0) was seq id: 242
last image line (61) was seq id: 303
Updated hdf file is: ./lev1/c271021b.hdf
./runc/c27102.sh: line 176: 4206 Segmentation fault aznav ${V} ${ATT} ${POS} -f 7 7 1 -so ${SCTOFF} -at ${GPTOFF} 0.0 -ao 0 0 0 ${ACVE} -h ${P_HDF1}


Run terminated due to data or parameter errors or program failure
===================================================================

comment:5 Changed 12 years ago by amro

  • Priority changed from minor to blocker

Mike ..I reprocessed the 271 ATM data without specifiying the timing of the lines and it worked perfectly ( so ATM finished). However, CASI is still a problem with and without spesifying flight lines timing ( starting and ending), although flight line one is okay ( wierred!) it is only line 2 and 3 are not working
error message
amro@pmpc816:~/scratch_space/271_WM06_17<1005>./runc/c27101.sh >./runc/c27101-output.txt;./runc/c27102.sh >./runc/c27102-output.txt;./runc/c27103.sh >./runc/c27103-output.txt;
1 word(s) parsed for 'GPS', instead of the expected 2

Creating Radiometric Sensitivity Coefficient Matrix
FSS Function disabled1 word(s) parsed for 'GPS', instead of the expected 2

Creating Radiometric Sensitivity Coefficient Matrix
FSS Function disabled./runc/c27102.sh: line 181: 27282 Segmentation fault aznav ${V} ${ATT} ${POS} -f 7 7 1 -so ${SCTOFF} -at ${GPTOFF} 0.0 -ao 0 0 0 ${ACVE} -h ${P_HDF1}
1 word(s) parsed for 'GPS', instead of the expected 2

Creating Radiometric Sensitivity Coefficient Matrix
FSS Function disabled./runc/c27103.sh: line 181: 27294 Segmentation fault aznav ${V} ${ATT} ${POS} -f 7 7 1 -so ${SCTOFF} -at ${GPTOFF} 0.0 -ao 0 0 0 ${ACVE} -h ${P_HDF1}

Action : I asked ARSF to reprocessed 271 Applanix file again but I can't see the point as how come it worked for ATM!

comment:6 Changed 12 years ago by mggr

ATM files accepted for delivery by Steve. Need to remove some white lines/bad scans though.

comment:7 Changed 12 years ago by mggr

Applanix reprocessed - retry CASI with his..

comment:8 Changed 12 years ago by amro

After reprocess the Applanix file on 12.july.2007 CASI data still have problem and won't be processed to lev3

comment:9 Changed 12 years ago by mggr

  • Resolution set to fixed
  • Status changed from assigned to closed

Got the CASI working ok - delivered both ATM (with funny colours and a warning) and CASI.

comment:10 Changed 10 years ago by mggr

  • Milestone set to 2006 data processing completion

comment:11 Changed 10 years ago by mggr

  • Component changed from ARSF to Processing: general
Note: See TracTickets for help on using tickets.