Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#166 closed support (fixed)

Support: 13/Jun/08, John Stevenson, IPY07/02, Lidar interpolation issue

Reported by: benj Owned by: benj
Priority: alpha 5 Milestone:
Component: Support Keywords: support lidar
Cc: Other processors:

Description (last modified by benj)

Query relating to Thingvallavatn (#98) lidar data - overlapping flight lines in opposite directions causing interpolation artefacts (see attached image).

We believe these are caused by the lidar being aimed down a steep slope flying one way and up it flying the other coupled to a slight boresight offset, causing a difference in exactly where it hits the slope in each case being calculated as the same location (hence why it only happens on steep slopes, and only on slopes that are either roughly parallel to or perpendicular to the plane, depending on which boresight angle is off).

Suggested solution is to average the lines using r.mapcalc in Grass prior to interpolation of null areas. If the slope is of a fairly constant gradient and the problem is caused by the above, this should hopefully produce reasonable results. Also asked Gabriel Amable at ULM for any suggestions. Given example data in ~arsf/support/20080813-JohnStevenson

Original email as below:


I am working on the 203_Thingvallavatn dataset.  I am processing the LiDAR to generate a 1 m DEM.  I have combined the xyz points from each of the .all files into one big file for processing.  When the data are plotted (via nearneigbor and grdview in GMT, or via and in GRASS, or and r.resamp.rst in GRASS), I find that some areas contain ESE-trending stripes.  These have a spacing of 3-5 m and an amplitude of a few 10s of centimetres.  The lines are perpendicular to the flightlines and I imagine that they are due to disagreement between data of different flights.

How do you recommend that I treat the data to remove these?  The stripes are only present on steeper slopes with a NNW to ENE aspect, so I am currently applying a filter to these areas (with the smooth=map parameter in r.resamp.rst).  Do you have any other suggestions?

I have attached some sample data points and a plot of the problem.



Attachments (1)

cone_artefacts.jpg (160.9 KB) - added by benj 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by benj

comment:1 Changed 10 years ago by benj

  • Description modified (diff)

comment:2 Changed 10 years ago by benj

  • Description modified (diff)

comment:3 Changed 9 years ago by benj

  • Resolution set to fixed
  • Status changed from new to closed

This was handled by Gabriel Amable, I don't think we ever heard what the conclusion was but we haven't heard anything back about this particular ticket. Closing.

comment:4 Changed 9 years ago by mggr

  • Component changed from ARSF to Support
Note: See TracTickets for help on using tickets.