Opened 9 years ago

Closed 9 years ago

#299 closed bug (fixed)

loading file x then adding file y causes an error message

Reported by: chrfi Owned by: chrfi
Priority: alpha 4 high Milestone:
Component: LAG Keywords: loading las child node fit
Cc: Other processors:

Description

Build number: 2010.01.18.1
system : pmpc973

to reproduce, the files are located in users/rsg/arsf/workspace/GB07_07-2009_277_inverclyde/leica/proc_laser. start up lag with no arguments, file, open, select the file LDR091004_131017_1.LAS and click add. Then select the file LDR091004_122647.LAS and click add, instead of simple adding the new line to the display (already showing the first line) an error message is printed to the command line. this is also true if you try to load both at the same time. However it does not occur if you open every file or other certain combinations.

Attachments (1)

command_line_output (507 bytes) - added by chrfi 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by chrfi

comment:1 Changed 9 years ago by chrfi

  • Owner changed from emca to chrfi
  • Status changed from new to assigned

having looked at the files it seems to be related to the fact that file y completely encompass file x, I believe there is a bug in the quadtree resizing and will look into it

comment:2 Changed 9 years ago by chrfi

  • Resolution set to fixed
  • Status changed from assigned to closed

this bug was caused by a typo in the expandboundary method which, if the current root node fell within the bottom left corner of the new area, failed to create the new bottom right node correctly. this has been fixed and tested.

Note: See TracTickets for help on using tickets.